Issues applying transformations in Blender to UE4 HELP!!!

Hi there! I have this one mesh divided into separate objects. It’s a movie theater based on one that I work
at and I wanted to create a cool scene (possibly game) with it. I’m a bored teenager what can I say?

Anyway, I made the layout of the building in a program called SweetHome 3D and then exported to OBJ.
I imported into Blender and spent weeks editing, adding stuff and cutting a lot of faces and triangles that were
unneeded that would possibly shrink lightmaps. Honestly I didn’t think this would work
but I unwrapped UVs and added some materials and imported in UE4 without combining the mesh and
BINGO it worked. My lighting built! It looked pretty good but I noticed a lot of stuff was misplaced and stretched.
For example you can see the polls in Blender are moved and scaled much larger in UE4.
I noticed it happened in Blender too only after I apply my transforms… So then I tried without applying
anything and it caused the same mess in UE4 but NOT in blender? I even created a whole new project
in UE4 to reimport the mesh and test it. Still no luck.
I tried to apply all types of transform (scale, rotate, loc), tried setting origins to 0
and tried many different things but nothing works… :frowning:

Please help!