Download

Issue with play editor dedicated server

Hello again forum!
I have been having crazy troubles the last week with UE4. I am not sure where to post this so I’m sorry if this is the wrong place to post this question, but I am using C++. I have been working on a multiplayer game on my own and tried to make a sprinting function with replication, netmulticasting and server to client functions. I thought I had the whole thing ready to go because it compiled correctly! I hit run dedicated server, play button and BAM black screen. Before adding my code everything worked. So I figured hey, why not just remove the code and maybe that’s it, just to see if it works. Nope, nothing. I tried:
using a new game same bug
removing code same bug
changing game modes , same bug
changing player controllers, same bug
making I had the right level, same bug
i have tried and tried I couldn’t get this to work, I even changed the level WHILE I was playing (if you hit the eye icon and the drop down it says “choose level”)
did I accidentally change something I didn’t mean to change? Also, before it messes up it changes the whole level to “untitled (play Edito…) gets rid of all players and everything. I thought it was the gamemode and the level but I’m still wrong. I am still wrong and it’s not just this game, it’s every other game after I hit Run dedicated sever. Do you need internet connection? Because when I code I’m on a base that is a literal bomb shelter and has no connection anywhere lol…