Download

Issue with fire_rifle_ironsights from AnimStarterPack as a montage

Hi,

I am trying to play the fire_rifle_ironsights animation as an animation montage. I’ve created other montages from this pack that playback fine, however this animation simply does not work. This isn’t an issue of forgetting about the default slot/default group in the anim graph. I’ve tests the code playing an existing montage and then playing this animation as a montage. Interesting enough if you choose this anim sequence (fire_rifle_ironsights) in the content browser, right click and choose “create anim montage”, you’ll notice that the preview window does not show the actual animation pose but some other strange pose.

I’ve tried in a fresh project to just test if it was something specific to my project and it doesnt work but the other fire animation like “fire_shotgun” works totally fine.

I can’t seem to figure out what it is about this specific animation that prevents it from working as a montage. Has anyone else run into this? This is on UE 4.26.2

Thanks

After thinking I was going crazy, I discovered that if I set the blend in and blend out of the montage to zero, everything worked. I am not sure if this is because the animation was short (quarter of a second) that with the blend in and blend out it was basically impercievable or if something else was up with that animation.

Anyway, I learned that montages seem to have blends that do not default to zero.