ISM on Spline in Child Blueprint

Hello there :wave:

I found a really weird issue that I hope to get some help with here. As it is really specific (I feel) I try to break it down as easy as possible, here are the steps I am doing:

  1. I have a parent “master spline ISM” BP which includes a spline and an “Instanced static mesh” (ISM) component
    SplineISMMaster

  2. In the construction script I am placing Instances of the ISM Component based on a distance variable (to set them apart, float) and a configurable amount of meshes (integer)

  3. I now have a child Blueprint of this “master spline ISM” and he doesn’t seem to be able to get the spline distances correctly and places the ISM Instances based on the “zero distance”. Weirdly he does place them but not at the correct distance but an offset based on the “zero distance”.

Here are some screenshots of the editor viewports for clarification:
Parent Blueprint (Spline ISM Master)

Chlid Blueprint

Maybe worth mentioning I am setting the configuration variables (mesh count, distance, offset) in the Child construction script to the Parent variables BEFORE running the parent construction script to make them editable inside the child BP.
I am also using an Offset which works fine in both Parent AND Child BP. Only referencing the spline seems to be an issue.

EDIT: I just found that you can just tick “show inherited variables” to set the parent config variables in the child BP. Doesn’t fix the issue though :frowning_face:

Any help appreciated!

Greetings,
Markus
Bagpack Games

After fiddling around (a lot) more I was able to isolate the problem, which was an offset of the whole spline component itself inside the child BP.
Somehow Unreal doesn’t take this into account when providing the spline locations (no matter if by distance or point index) in relative space.

So here is my solution for anyone with the same problem:

  1. Check if your spline component has a relative offset
  2. If so, change all your references where you get spline locations/rotations to “World”
  3. Make sure you also set the locations/rotations etc. as world space (for ISM there is a bool specifically for this)
  4. Be happy your meshes align perfectly on the spline again! :grin:

Best regards,
Markus
Bagpack Games