Download

IOS provision and signing key not found. Both show valid in the project settings.

Hi I get this error when packaging:

IPP WARNING: Failed to find a valid matching mobile provision, will attempt to use the embedded mobile provision instead if present
IPP ERROR: No Provision or cert found!!
PackagingResults:Error: Error Provision not found. A provision is required for deploying your app to the device.
PackagingResults:Error: Error Signing key not found. The app could not be digitally signed, because the signing key is not configured.

Worked fine yesterday. I can package the game anyway but it fails when i try to upload it to iconnect.

Does anyone have a solution for this?

Provisioning and code signing issues have always been somewhat of a pain. A build that worked yesterday can commonly not work the next. I would suggest building/deploying from Xcode as at is generally more verbose about issues that the UE editor. Likely it will give you the same errors but from those errors/warnings you can search for common solutions. What is the error/warning you are receiving when uploading to iTunesConnect?

I had the same issue. For me it turned out that I was using not the lastest version of OSX but the latest version of unreal. Due to the corporate software lock down I can’t updated to the latest OSX so I went to a previous version of unreal and everything worked fine. To be specific I was using OSX El capitan and 4.14 which caused issues. 4.12 works fine.

I had the same issue and exporting certificates from Keychain helped me.