Download

iOS Build with 4.6 Succeeds, but submission with Application Loader has Error

So our App is building and submitting fine under 4.5.1, but we ported up to 4.6 when it was released. Things went pretty smoothly, including being able to build a clean ipa, until we tried to submit though the Application Loader when we received this error.


ERROR ITMS-9000: “No architectures in the binary. Lipo failed to detect any architectures in the bundle executable.”

We also tried to start with a fresh info.plist file with no success.

Again, the game is building without error, but Application Loader is throwing the error. Any ideas?

You can view the Answerhub post here, but no assistance has been provided so far.

here’s an associated issue on answerhub that maybe the same problem, though i haven’t gotten this to work yet.

https://answers.unrealengine.com/questions/94493/application-loader-error-9000.html

I have found a clue to this problem. NOTE: I am having the same exact issue with UE v4.6.1 builds for iOS.

If you take the IPA file created by v4.6.1 and unzip it on a Mac, you get a Payload directory. Inside that is the APP file. And inside of that are the executable and all the data files. If you run the lipo command line app on the executable, it says:

fatal error: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/lipo: truncated or malformed fat file (offset plus size of cputype (16777228) cpusubtype (0) extends past the end of the file) UE4Game

Doing the same sequence on an old build made with v4.5.1, which uploaded correctly to iTunes, I get:

input file UE4Game is not a fat file
Non-fat file: UE4Game is architecture: armv7

My conclusion is that the UE4Game executable being bundled into the IPA file is CORRUPT.