Download

Instantiated static meshes don't show materials when instantiated at runtime.

When i instantiate static meshes in the construction blueprint it the meshes are rendered with material. No issues here.
But this is not what i want, the material depends upon data that is loaded after the construction event.
My solution is i spawn actors of one of my classes and put all meshes with one material in a designated actor for this material.
The problem is: the texture does not show. Also not the texture in the materials tab. The material shows that designates that no material is assigned.
I tried setting the material with the set material node and also with create dynamic material instance.
It drives me crazy. hopefully someone can help.

I am running under linux. I tried rebooting because maybe it was a video memory issue.

There’s a checkbox in the material settings I think that you have to check under something like material usage for instance static meshes

That was it!
In the material under the usage tab there are a bunch of checkboxes where the material is used for.
Among them ‘Used with instanced static mesh’.
It works perfectly now.

thank you!