Ingame viewport flipped upside down

Hi, um, somehow I managed to make my ingame viewport flip upside down. This is what it looks like - http://imgur.com/uPjhZ5Z

I was able to fix it by playing from the viewport, but I dont think that that is a good long-term solution.

Hi Noahdutch,

You probably got this way by holding Alt while flying around with the camera. This enables the Maya camera mode. You can set yourself right by holding Alt+LeftMouse while you move around again.

Cheers!

Happens to me at least once a day. Can only fix it by switching to game view in the viewport and then exit again.

Thanks Stephen, you’re the boss!

Im sorry but in my case, holding ALT + Left Mouse doesnt resolve the problem since when I don’t hold Alt anymore, the view is coming back to its original state (upside down…)

Hi Promethee47,

Are you on a mac or PC? Does the viewport camera show the viewport upside down in every new project you create or just a custom project you are working on? Did you start with one of the project templates, are did you start with a blank project? Please respond with the answers to these qusestions and we will continue to investigate.

Thanks,

Steve H.

I have the same wierd issue. It seems to come into affect after scultping landscapes.

Edit: My issue was ironically that my Rift was lying upside down and UE took camera input from it.

I also notice in 14.5.3 that my rift HMD orientation is now affecting the play-in-viewport function in the editor… I checked in editor preferences > level editor > play > and saw an option called Viewport Gets HMDControl, but it was already disabled so I’m not sure what is causing this… it didn’t happen to me until I updated to 14.5.3 from 14.5.2