Download

Importing Skeletal Meshes into Unreal Problems

Hello there,

For the past 3 days I have been trying to import my character into Unreal Engine, which I based off MakeHuman UE4 preset. After I have finished building this character, I have found out from a thread on these forums, that in fact the UE4 preset doesn’t work at all with Unreal. I have been asking myself why did they even call it UE4 preset, since the only thing that is similar is the joint hierarchy. Otherwise the rotations and scales are all wrong.
So I have tried to import a default UE4 Mannequin which I exported directly from UE4. But even that doesn’t really work, when I import it back. The skeleton and mesh gets grouped, so it cannot be synchronized with the default animations anymore, and when I try to ungroup it, it messes up in Maya.

1: - Can I download somewhere a default skeleton for UE4, where all the animations would work? Something I could build my mesh around?
2: - Since character is done, rigged and weighted, is it possible to somehow reset the rotations of the bones into UE4 format? I have tried with HumanIK, but that didn’t work, since it’s just retargetting, these are the differences of rotations:
c6a42e658192ab7ff97f0bc62b0a8e50bccf2b0e.jpeg
3: - Why does it happen that when I ungroup in Maya the default Mannequin, the mesh rotates 90 degrees? How can I solve this?:
b89d649eafa115171449cf0c1e27fd6c63745a9e.jpeg
4: - There are just weird scales of the root bone. Sometimes it’s 10, 100, 1, 0.1, can I somehow reset it to just 1? When I try to freeze transformation, it says the joint is weighted.

A lot of questions, sorry! But I would gladly appreciate the help.
Pav

  1. You can export the default skeleton right from UE4 into an FBX file by right-clicking on the asset in the Content Browser.

I’ve leave 2-4 for people who know Maya :slight_smile:

Yes, I did that. But it gets grouped when I import it back to Maya. If I import to other packages it gets rotated.
After I rotate it, import it back to Unreal, the animations kind of work but it has errors.
Capture7.JPG