Download

Importing from Maya

Hey everyone, please bear with me as I am in the process of learning UDK.

I created a fence prop in Maya and exported as an FBX, I was able to import everything fine into UE4, for the most part. I created a simple scene and added my newly imported prop and it looked terrible. I started messing around with the Material Editor but couldn’t get it looking any better. Two of the attached images are Maya renders and you can see there is a huge difference between the renders and what’s in UDK.

I noticed that the bump map I used in Maya is converted to a Normal Map, however, it doesn’t seem to actually hold any of the deformation data. There is also a dark shadow on the top of the fence posts that cant be scene in the Maya renders. After reading up a little I realized (not sure if this matters anyway) that UDK does not support TIFF files, after seeing that I changed my texture files to TGA but now I can’t import them.

So a few question based on the above;

  1. Do I need to do something special to get the generated Normal Map to hold onto the deformation data of a bump map?
  2. Is there a way to use the Bump Map and not have to convert it to a Normal Map or is this a dumb idea?
  3. Why is there a crazy dark shadow that I cant seem to get rid of, is it multiplying my spec map?

Hopefully this all makes sense, as I said, this is the first time I have opened a game engine and created something specifically for that case.

I would generate your normal maps outside of UE4 and use them instead of a bump map, Nvidia has a normal map plugin that can convert bump maps to normal maps and I’d just do something like that.
Your texture map is a bit different because you need to adjust the tiling in the material, open the material and plug in a Texture Coordinate node into your Texture node, you can then adjust the UV tiling there.
When using a normal map, add “_normal” to the file name and it will recognize that it’s a normal map when it imports to UE4, since there’s some special texture settings it needs for normal maps.
The black mark is likely due to issues with your lightmap UV’s, by default UE4 will try to generate lightmap UV’s for your mesh, but it doesn’t always do a good job, it’s best to do it yourself and then disable that option when you import to UE4, best workflow is that your first UV channel is for your material, second UV channel is for your lightmap and if you have the two UV channels it will automatically use the second one for lightmaps as long as you don’t have it set to generate lightmap UV’s when it imports. Here’s info about creating lightmap UV’s: Unwrapping UVs for Lightmaps | Unreal Engine Documentation
After that, you need to then adjust the lightmap resolution, you can set that by opening the static mesh and adjusting the properties, or select the item in the level and adjust the lightmap override in the actor properties(though that only gets applied to that specific item in the level).

Thanks dude, I will mess around with it and get back with my results.