Importing a mesh with LOD crashes UE4

Whenever I import a mesh with lod (any amount of meshes in lod) into Unreal Engine 4.6, it immediately crashes the editor. I have tried limiting how many lod my mesh has and double checked the ‘FBX pipeline documentation’. There’s no solution I can figure out. It does not happen in 4.5 or older, just 4.6. I am using Maya 2015 exporting as a .fbx 2013 binary file with normal setting checked as shown in ‘FBX pipeline documentation’.

Hi Oblivion,

I’m not seeing the same thing on my end, but that doesn’t mean there isn’t a few things we can try. I’ve tried this with Max 2013 and Maya 2014 using LODs.

  1. How many LODs are you currently using? I know you said Any amount, but there is a maximum of 4 (Base, plus three lower LODs)
  2. When you import can you try do so without the “Generate Lightmap UVs” selected in the import settings box?
  3. The documentation is a little outdated on the Docs page. The FBX importer has been upgraded to FBX 2014. Can you try using that?
  4. Would you be willing to share an asset that is known to crash for you so I can test? It can be a simple asset, so long as it’s causing the error on your end I can take a look. FBX is all that is needed.
  5. Since you are getting a crash can you include your crash logs and dmp from your project in the saved folder along with the call stack copied to a txt document and included in the zip?

Thank you!


Okay, I know that the maximum LODs I can have is 4. That is what I usually use for each mesh. Good to know that FBX 2014 is supported now.

I was able to reproduce the crash again and uploaded the crash log/dmp files to this message. Also I tried your solution by unchecking “Generate Lightmap UVs” in the import settings box, and that fixed the problem. Looks like I have to manually go into the static mesh editor and check “Generate Lightmap UVs” for each LOD mesh.

Yes, I’m willing to share a simple asset (.fbx file) along with the crash log/dmp files, so you guys can fix the “Generate Lightmap UVs” for LOD meshes imports problem/bug.

LODs Crash Logs/Dmp Files

Test Door Mesh FBX file

Awesome! I’m glad that resolved the issue! I’ll add your information to the list and respond back once we have a fix integrated.

For the moment it’s best to make your own lightmaps or try generating once you’ve imported the mesh.

Thank you!


This bug has recently been fixed and will be in 4.7. You can test this out with the 4.7 preview builds that are currently available via the launcher or once the final build of 4.7 is released.

The fixed CL is 2400339.

Thank you!