Download

Import skeletal mesh from Blender and make a really simple animation on Uneal

Hello Everyone,

Since three days, I have a big problem (but maybe easy to resolve).

I have done a skeletal Mesh from Blender (a simple furniture, like a tray).

A export to Blender in .fbx file.

I import to Unreal my .fbx and all is fine (Visually talking)

The problem is I can’t just make a animation about to open or close the tray !

My bone is present, but when I record on Animation Sequence Editor the closing and the opening which is fine for me (I just translate the bone which is connected to the tray for closing and opening).

If I play the animation just to see if all is right, the mesh without the tray is rotated to the floor and the scale is really big.

Moreover, the door where the bone is, is really little.

If you need any more informations, please tell me, I’m really lost.

Why not animate in Blender instead? You should make sure that the unit scale in the scene settings in Blender is set to metric and 0.01 scale and that it’s facing the right direction in Blender (-y forward).

Thanks for your answer cyaoeu.

I understand what you said, but I have made on Blender before the creation of the skeletal mesh, I have made a scale to 0.01 and metrics units.

I have also made a rotation on z (90 degrees).

Can you share the .blend file?

Of course.

https://1fichier.com/?a7prjbh04z

This might not be related to the problem, but I’d have at least 3 bones, one for root, one for the door and for the rest. Rotation settings at export wouldn’t affect the animation in unreal.

If you select the rig you can see in Transform under Scale: that you’ve got 0.080 scale, this should be 1. Same for the mesh, instead of 0.010/0.010/0.002 it should be 1/1/1. Also you don’t rotations on the objects either. To fix everything first select the armature and press scacebar and search for Apply Object Transform, then in the bottom left tick Scale and then Rotation. You can even do Location if you want to.

I didn’t notice this at first but your mesh is not facing the right direction, the front should face -Y, so along the green grid line in Blender. You can rotate the armature in object mode along Z and do Apply Object Transforms again. Finally you’ve only got one bone so every vertex will follow this bone instead of only the vertices of the shelf. To fix this go into Edit mode for the armature, add a new bone and rename it to Root or something, then select the other bone and in the Bone settings (bone icon) under Relations click the Parent: field and select the Root bone.

Then you can animate in Blender, select the bone for the shelf and select frame 1 in the timeline, press i to insert a keyframe and select LocRot. Go to frame 50 or whatever, rotate the bone and insert another keyframe. Then export that and you should end up with an animation that looks okay.

Thanks a lot, I will try this as soon as possible :slight_smile:

Just make sure you apply transforms for both the armature and the mesh (in that order).

Thank you, it works really well ! I will continue to work hard to make the game of my dreams :slight_smile: