Download

import an ue4.7 project in ue4.10.4 or better ue4.11.1

hi!

i got an project made in ue4.7 which worked fine in this version.

now i want to upgrade this project (for using some new features) with an newer version of ue,

so i tried to start the ue4.11.1 version:

  • it always crashes during the loading process.

after several trials i decided to load ue4
.10.4

  • i installed the substance plugin
  • i made an copy from my project from ue4.7
  • i started the ue4.10.4
  • a message appears, which says:

“plugin “substance” failed to load because the module” substance core"
does not appear to be compatible with the current version of the engine.
the plugin may need to recompile"

  • after this message the ue4.10.4 stops loading.

is there an way to bring my ue4.7 properly into an newer Version like ue4.11.1 or ue4.10.4?

thank you very much for an answer!

greetz
loopon

ps.
i downloaded the substance-plugin-update, but this is the only result i got by now:
e3944bbea963939766f7b499865f26d461d9747f.jpeg

and after this error, ue4.11.1 crashes

Hi loopon,

How are you binding the Substance Plugin to your project? Is the Substance Plugin being installed from the Marketplace, or is it located in your Project/Plugins folder?

hi :slight_smile:

the substance plugin is installed from the marketplace.

Hi loopon,

Thanks. It is curious that this message is showing up. Do you have a copy of the substance plugin in your project folder?

hi support,

the ue4.11.1 - version was an copyfrom my ue4.7-project ( recommended by the launcher during the installation process of ue4.11.1).
after this installation i went to the marketplace and loaded down the plugin.

Hi loopon,

Can you take a screenshot of your Unreal Project folder and post it here, or email it to josh.coyne@allegorithmic.com ? I have provided a picture as an example. It should be the folder with your .uproject file.

projectFolder.png

hi allegorithmic support,

during the installing process of ue4.11.1 those 2 errors are popping up…
after these errors the installation quits…

UE4.11.1-FirstError.JPG

d2e8ce30766537d9207c6ffb6a54446542eca82b.jpeg

Hi loopon,

It sounds like you may have a copy of the substance plugin in your project folder. Could you verify that one isn’t there?

hi support,

in ue4.7 i have an manually installed substance plugin… should i ´remove it before installing ue4.11.1 ?

Hi loopon,

Here is what I’d recommend you do:

  • Copy and paste your UE4.7 Project
  • Delete the Plugins/Substance folder from the UE 4.7 Project
  • Ensure UE 4.11 in Epic Marketplace has Substance Plugin installed
  • Upgrade copied project to 4.11

You shouldn’t get any conflict warnings at that point.

hi allegorithmic support,

that worked :slight_smile:

thanx a lot!!

Hi loopon,

Excellent! I’m glad it worked out for you :slight_smile: