I have problems with anything that needs to be assigned, levels, actors etc;

For some reason, every time I create something whether it be a new level, pawn, widget, materials etc; I am unable to assigning to various things.
I think it maybe important to outline that I am using Blueprints

Examples:

  1. I have created many levels but when I try to add any of them to the Game Default Map, it does not assign. The level shows in the drop down menu but once clicked nothing happens, I have also tried to drag the level over and the Default Map section turns Green but once I drop the created level in, nothing happens.

  2. When I create a new material and drag it over to be used on anything, although the Material section turns green, once I drop the new material in, nothing happens.

  3. I created a actor that attaches to a spline which works perfectly fine on every other game I have used it on but when I try to attach the actor to the spline, it does not attach. .

The same thing also happens with widgets.

I have tried re-importing everything into a new project but the problem keeps occurring ONCE I save the project.

Thanks in advance