Download

I have a question about vertexcolor

  • I made a hollow cylinder in 3Dmax,Set the alpha value of the outermost point to 0, the alpha value of the middle point to 50, and the alpha value of the innermost point to 100。
  • However, after importing UE4, set the transparency with the alpha channel of vertexcolor,The outer layer is transparent and the middle layer is opaque and the inner layer is transparent。
  • I don’t know why?

Picture please?

You probably are using “Translucent” as blend mode in the UE4 material. Unreal is very bad when it comes to transparent surfaces as it can’t render order independant transpareny. So you have to choose between translucent or masked. If you use translucent blend mode you can get nice smooth fade out in transparency, but the entire object will be slightly transparent. If you chose “masked” blendmode, your object stays 100% visible and only the masked areas get 0% visible. Problem here is, that there is no chance for a smooth transition, it only recognized 0 and 100 values, nothing inbetween. A way to smooth it out is to use the Dither function inside the material but it looks a bit weird. However, it’s your only option.

I use the Translucent, but I just want the center face to be opaque black. If I set the peripheral point to 100, there will be a black effect. Only the center can’t.thanks vary much。