Download

I can't get the weapon root of my fps weapon to animate.

I can’t get the weapon root of my fps weapon to animate. Tried all the different options on root motion. Is this a bug or am I doing something wrong? I mean it should be possible, if for example I want a floating cube to be a 3d mesh attached to my character that I can translate and rotate how I want.

Tried the same for the slide on the weapon, once imported into UE4 it won’t move. However re-exporting it from UE4 into my modeling package does contain the animation.
Advice on this issue would be very helpful.

Sorry, I might be missing something and sound a little dumb, but have you checked that your gun mesh has a single bone hierarchy and the bones have skin binding?
Also see if any constraints are causing this issue. Remove them if possible by baking keys only on the bones and export just the mesh and bones.
A screenshot might help.

Thanks for the advice. However my problem was something entirely different. When I added another bone at the base of the hierarchy ( new root) then all the bones after it animated ingame. UE4 appears to have some safeguards in place to prevent root motion.