Download

I am unable to complie UE4.2 with VS 2013. What could be the problem? Please help me!

I have problem with compiling.
I always get error, and i couldn’t find any useful tips on the net that’s why i opened this thread.

This is the error list I got.
http://kepfeltoltes.hu/140615/unreal_error_-editor_www.kepfeltoltes.hu.jpg

I have Windows 7 Ultimate 64Bit.
I have installed Win 7 SP1, as it requires.
I have a VS 2013 ultimate with update 2 (registered). I started it with ‘run as admin’ mode.
I have installed all of the files on the VS 2013 installer disk, from the “packages\Win81_SDK” all the 21 installer files. except 2 as it didn’t allow me to install. So I installed 19.(I now i don’t need all of them, but i didn’t now witch is important and i didn’t want to miss any.
I have installed June 2010 DirectX runtime.
I have put all the folders together and I put it into the root of C: and I tried on D: Drive. I think I tried C/programfiles as well. Were did you put the “UnrealEngine” folder?
I have set the menu in visual studio, as the video shows on youtube. https://www.youtube.com/watch?v=usjlNHPn-jo&feature=player_detailpage#t=397
Then just after this, I clicked on “Built” It started but after a while (about 30-60seconds) I got several error, and didn’t make me the files to start UE4.

I read that maybe i have to change some line in some file, but i don’t exactly now what. Did you have to do anything like it?
And I read in youtube comment, it will use 17 Gb after compiled UE4. Is it true?

Please somebody help me!

Something seems wrong with your platform includes. Please double check that you have a folder that looks like “C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\include”. This is the folder where the Visual C++ runtime headers are included by the engine from, and if the folder doesn’t exist or is missing files like “new”, it’s very likely there was a problem with your Visual Studio install.

It could also be that the above is the problem. You should not have needed to install any additional Windows SDK files, as the correct version of the Windows SDK that you need is included with Visual Studio 2013 when you install it. Visual Studio’s installer will put this in the “C:\Program Files (x86)\Windows Kits\8.1” folder, unless for some reason you already had it installed on your computer. Then it sets a registry key that UE4 looks up to figure out where it is installed at. It’s possible that installing Windows SDKs afterwards has caused the registry key to point to some invalid location. Can you take a peek in the “C:\Program Files (x86)\Windows Kits\8.1” and make sure that it has an “Include” sub-folder with lots of files under it’s sub-folders?

–Mike