Download

Hundreds of "Cant Find File" When Packaging Game

So my game runs fine. It even runs fine when packaged (aside from my UI not showing up for some reason…)

But I have hundreds, if not thousands, of “failed to load asset: can’t find file” warnings when I package the game. I believe I moved things around using the explorer, but this was so long ago, and I don’t know how to fix it now.

I’ve tried “fix redirectors”, I’ve tried re-building the project when packaging, and I still get hundreds of these errors and I can’t possibly fix them all manually…

Does anyone know how I should fix this?

1 Like

Yeah those warnings are super annoying.

The annoying fix I found was, to look at what files it’s trying to load, create a file in that same location with the name it’s complaining about, and then try and delete that file. It’ll probably say what’s referencing it then. If you get that just go into the thing reference it, change it, then delete the file again.

Just saw you don’t wanna fix them manually. You can try bringing those files over to a new project and see what happens

1 Like