Download

How to properly capture ONE shot from Scene Capture 2D with PostProcess?

Scene Capture 2D needs to have “Capture Every Frame” enabled in order to display any PostProcess (Capture Source: Final Color (LDR with PostProcess)) - but I would like to capture it only once, without leaving it capturing every frame all the time (huge performance loss) - how to do it properly?

For now I do something like this: Enable Capture Every Frame -> Delay 0.03s -> Disable Capture Every Frame.

It kind of works, but not always. Sometimes it doesn’t take a picture. I would like to minimize this delay, because the longer it lasts, the more visible the lag is… I hope that there is some other way than enabling, delaying and disabling ‘Capture Every Frame’. I’ve also tried with “Update Content”, but it does nothing. Any clues?

i’m having the same problem in 4.21.

Not sure about 4.21, but in 4.23 it seems to work when using the CaptureScene function, with CaptureEveryFrame turned off on the component. It captures a scene with postProcess materials properly, Capture Source is set to Final Color (HDR) or Final Color (LDR). I also have the *Always Persist Rendering State *on. My component uses Orthographic Projection Type though, so maybe that’s also important.

“*Always Persist Rendering State *”=checked resolve my problem and now capture entire scene and with the correct colors. Thank you Slavq