Download

How to make Oculus VR works?

Does Oculus VR work out of the shelf for UDK4?
How can I turn it on? Do I need to edit any files inside UDK4 installation?

Thanks in advance!

Start with Wiki: Oculus Rift.

Thanks! It was very helpful!

I have my oculus plugged in (and I can run the oculus tuscany demo just fine), and I packaged a project (just the default blank code with content two chairs demo) into a myproject.exe, but when I launch it, it does not detect any rift, and I remain in a regular windowed screen. Any troubleshooting suggestions?

Swap to fullscreen (alt+enter) and it should go to the Rift (as long as your HMD is plugged in).

Oh wow, that was so easy! I feel stupid but thank you very much, worked like a charm.

I am on a Mac. When I enter fullscreen, it still does not recognize the Rift. I tried entering ‘stereo on’ but that didn’t do anything either. Any ideas?

Going by the souce, its currently windows only.



#define OCULUS_RIFT_SUPPORTED_PLATFORMS PLATFORM_WINDOWS


Eta?

Seems like the plugin is there on mac - anyone have an ETA for oculus support on the mac?

It might be helpful to have information about what the platform limitation is so that the community might help facilitate it’s implementation for platforms other than Windows.

Oculus support for the Mac is in the works

This thread might get updated first when support is released.

Windows 7 crashing from any key combination using the Rift with a standalone

Hi All,

I’m running a
Boxx workstation
With 16 gigs ram
Dual quad core Xeon processor
Nvidia Quadro 4000
Windows 7
Fresh install of UE4 verified.
The built-in Oculus plugin Is enabled.

I built a standalone of the Realistic Rendering demo.
It works fine when not using the Rift but once in Rift there is no head tracking and the view is as if you are looking through a telescope at a part of the room.

The real problem however is that while attempting to use the Rift any keyboard sequence (“Alt-Enter”, “~ / tilde”) locks and crashes my computer.
I tried this twice and get the same result.

I already consulted the Oculus Wiki on UE4 and stepped through the Sanity Check but no help.

I’m assuming that this is not necessarily a video card issue but some issue with using the Rift?

Any ideas to resolve problem would be highly appreciated?

Thanks in advance!

Michael

Are you able to detect the Rift using the configuration program included with the Oculus SDK?

oculus fully functioning outside of UE4

Yes, I can use the configuration program included with the Oculus SDK. I can use the Oculus with Unity with no problem, I can use it
with VR Player with no problem, I can run any demo I’ve come across so far. I can use the C++ starter program to detect head rotation tracking.
The issue certainly has something to do with using the Rift with UE4.

Again, I have no problem running UE4 without the Rift.

Are there some settings or ini file etc. that might be the culprit?
Might it have something to do with the hardware specs of my computer given the **combination **of using the Rift with UE4?

Thanks in advance!