How to I get past the sufficient permission warning?

I’m trying to add a socket to my skeletal mesh and I get the following message.

You do not have sufficient permission
to save the following content to disk.
Any changes you make to this content
will only apply during the current
editor session.


Just wondering how I can bypass that. Do I need to run the Rocket Editor as Administrator? I should already have elevated permissions.

Strange…i got the same warning about permission to save to disk when i first downloaded Beta 5 then it failed and i thought it was my computer. Then it worked the second time. Not sure if it helps you but i wanted to post here since it is the same weird warning out of nowhere.

Hi Charles,

I recommend checking the .uasset file for the Skeleton and/or the SkeletalMesh in Window Explorer and making sure that they are not marked as Read Only.

Let us know if that helps.

They aren’t marked read only. I was actually working on trying to fix another bug and had to Log in as Administrator on my PC to uninstall Rocket.

After reinstalling and still logged in as Administrator, I decided to try to add the socket and save and it worked fine. Even though my regular account has Admin Privileges, I cannot add sockets and save unless I’m logged in as the Administrator.

Running Rocket as Administrator fixes this issue.

What I found, is that you cannot save your projects if they are within the Rocket folder. (Generally C:/ProgramFiles/Rocket.

So what I do is have all of my projects in another folder (either My Documents, or SkyDrive), and that way you always have sufficient permission to save.

The Rocket folder is reserved for just the engine’s files. Hopefully that helps to clarify things.