How to enable Chaos

I haven’t uploaded them yet. I have Google Drive(15gb). There 4 files 10.5 gb(3). Do you want them? I would have to put them 1 at a time on my GD. Do have a drive that is bigger?

@TheProffesor Are you ever gonna try the two buildings in the chaos map ?

it’s broken for everyone !

That may be against Epic’s EULA’s?

Anyway, following the steps I’ve gotten 4.25.1 to work just fine with Chaos. You might as well just wait though, it’s very slow and buggy at the moment. You may have better luck with the dev branches as they are continuously improving/working on Chaos related stuff in those branches.

Edit: In fact, if anyone’s still having trouble. Just make sure you have the latest 4.25.1 source code built with the stuff from the first post added to the and create a new blank project with no starter material. Then just copy over the content folder from the chaosdestructiondemo project to your new project and start it up. It may say something about rebuilding the project, just click no as that seems to be broken, it should still load up fine for you to test.

Guys this dude made a download link of the complied version with chaos demo EveryThing WORKING ! including the 2 big buildings all fully working and only 7gb. Here is a link…w?usp=drivesdk

When try the Chaos project and give the path for the compiled version it doesn’t load and execute the project. Not a big deal because I have a compiled version of 4.25 working. I was bored yesterday.

Dont work, already compiled and followed all the steps, dont work. The Chaos Editor button dont appear and nothing works
It’s very frustating, can someone help me?

It doesn’t work, I’ve compiled everything. It took almost 20 hours to finish, I enabled the plugins, and nothing; Not even the Chaos Editor button appears.
It is very frustrating, can someone help me?


thats a dead link…

me too, tryed 3 times, every method…

I noticed if you try and open the chaos demo from the launcher it errors after setting it up.
the workaround is to show in folder and then rightclick the uproject file and switch engine versions to the source build.
its not setting its self to the souece build unless you manually set it. Just an FYI <3

when you get the source make sure you get the 4.25-plus

and when you extract it some reason if you use winrar it extracts as a folder in a folder.
you need to make your folder structure look like this

read my last message.

Chaos NOOB guide with pictures.

Please refer anyone not getting it to work to this post.

step 1 download the source from github.(make sure to get the branch 4.25-plus) NOTE: i tried with all 4.25 branches. 4.25-plus is the one that i got to work.
none of the other branches seemed to compile so now you know the secret.

extract that to the ROOT of a drive and make sure it does not have a folder in a folder like

d:\ue4\ue4 otherwise adding the demo project wont add it to the right location add it to the folder you extracted as victor said will not put it in the right folder. so cut and paste the files
to be in the root drive in a folder. i named mine UES4.25 this stands for unreal engine source 4.25

after that in the launcher make a destruction demo project for 4.25 DONOT CHANGE THE NAME…
now move that folder once finished inside your UES4.25 folder and you will see this below


Now find the file called UE4Editor.Target.cs (most important step here)
make it say the following code add the 2 red lines below to that file

// Copyright Epic Games, Inc. All Rights Reserved.

using UnrealBuildTool;
using System.Collections.Generic;

public class UE4EditorTarget : TargetRules
public UE4EditorTarget( TargetInfo Target ) : base(Target)
Type = TargetType.Editor;
BuildEnvironment = TargetBuildEnvironment.Shared;
bBuildAllModules = true;
bCompileChaos = true;
bUseChaos = true;

SAVE THE FILES CHANGES then proceed below

now click on setup.bat, it will take a while to download dependencies depending on your net
speed it can take a while.

WAIT till the download finishes and the command prompt closes
before you proceed below

after the prompt goes away then click generateprojectfiles.bat. it will then add a few things and an UE4.sln
it may just be called UE4 if you have file extentions hidden like windows does by default.
now open the UE4.sln it will load visual studio.

if you DONT see chaos destruction demo in visual studio like in this image below then your chaos demo folder is not in the right place.


click at the top where it says build like in this image and click build solution


let it build. it will take an hour or 3 or 15 hours depending on the paper weight PC you are using. :stuck_out_tongue:

after that is done goto the destructiondemo.uproject file
rightclick it and goto switch engine versions and switch it to the source build of 4.25


after that is done click the project file and it will run! bing bang boom now in the editor modes you have chaos



GG you GOT IT!

HERE is your step by step guide, now don’t choke on the silver spoon feeding please :stuck_out_tongue:

see my post above. its an easy process. just takes time waiting on dependencies to download and for the project to build. this tech is in beta. it will work in the launcher version once it is OUT of beta. few more months i presume. i gave a spoon fed step by step guide above. read it, do it. love it

I tried to put one of the files on my GD(10.5gb) and GD timed out. If you have some ware to put them let me know. It is about 50gb. 5 files. This will take about 8hrs. I get 10 up.

try mediafire. its like $5 a month for 1TB space unlimited downloading etc.

Thank you for writing that guide frostic! I wish there were more users like you sharing Chaos information and experiments. I will try this for sure.

you are welcome. and if you got any questions about getting it to work send me a private message and i’ll invite you to my discord. I try to help when i can but I’m a noob myself.
we all need help sometimes. ppl here help me so i try to do the same and help when i can.

Update: A restart and a new build later it worked, my bad.

Hello, perhaps anyone can offer a bit of assistance, I couldn’t find an answer via search.
I have the Chaos enabled and it works fine for the most part, but I seem to be missing functions mentioned in the “Chaos Fundamentals” YT video that was released earlier.
All of the “Field Construction” scripts are missing, the video is almost half a year old now, so I guess things have changed significantly, if that’s the case is there an updated guide to the field systems?