Download

How to enable Chaos

General perf question for everyone. There seems to be a perf gap since the 4.23 release of chaos, at least within the test levels. On the order of 10-12ms increase for the same content. And in some instances what had been running smoothly in 4.23 (the scripted destruction of the building in the “Geometry_Collections” level) can dip way down into the red, teens and single digits in 4.24 and 4.25.

I’m assuming this is true for everyone else and not something specific to my build(s). Is that correct?

No, this is not the control I am looking for.
I WANT to fracture very small pieces, however because of their small size they have cannot hurt players when hitting them, or provide cover. These small pieces are literally useless once removed from their original spot, which is why I want to delete them instantly.
You just have to spawn some dust FX to hide this trick.

This trick is described here : https://www.gdcvault.com/play/102330…Destruction-in
and here : https://www.gdcvault.com/play/102300…Destruction-in

I didn’t manage to get the demo running in 4.23 but I tried it in 4.25 and yeah, the performances are terribly bad. In 4.23 I remember the destruction was lagging a lot but not the framerate because the destruction was happening in a separated thread, however in 4.25 it seems the destruction impacts the frame rate… I reached 5-10 FPS when running through a showroom to activate all triggers in the same time.

Hello. I was able to compile 4.25 with the template demo following the instructions but when i run the default map, it starts fine but it crashes once it starts simulating (after pressing a button in the map), any pointers?

Did you get your explanation? Because I can’t make it work here… Could you show the different steps please?

Seems like the only possible way through my experiments is to use the variable bOverrideBuildEnvironment in your project EditorTarget cs file.



bCompileChaos = true;
bUseChaos = true;
bOverrideBuildEnvironment = true;


I don’t understand this setting so much really as it basically skips the validation of modules that require a unique build when using a shared build of the engine but it does compile and start the engine at least. I really hope we hear something from some devs here

My 4.25 demo runs if I follow the documentation’s steps. However, if I want to launch it from the UE4Editor.exe I generated, it tells me “this project was built with a different engine, rebuilt now?” and then the rebuild fails.

My ChaosDestructionDemoEditor.Target.cs file contains this :


Type = TargetType.Editor;

ExtraModuleNames.AddRange( new string] { "ChaosDestructionDemo" } );

bCompileChaos = true;
bUseChaos = true;
bCompilePhysX = true;
bCompileAPEX = true;
bCompileNvCloth = true;
bCustomSceneQueryStructure = true;
BuildEnvironment = TargetBuildEnvironment.Unique;

Unreal told me there was a problem with


bUseChaos = true;

and told me to use


BuildEnvironment = TargetBuildEnvironment.Unique;

or


bOverrideBuildEnvironment = true;

but both did not work, I had to remove


bUseChaos = true;

. Now the engine tells me “ChaosDestructionDemo could not be compiled. Try rebuilding from source manually.”…

To resume, I can work with the demo by following the documentation’s steps, but it requires to keep a dedicated engine only for it because there is a problem with this step from the documentation :
6. Build the ChaosDestructionDemo for Development Editor (should be the default Visual Studio configuration). This will build the whole engine, with Chaos, since it’s already setup in the project’s Target file.” -> this does not generate an UE4Editor.exe

So I have a 2nd engine I built the “classic” way, with Chaos working great and a generated .exe, but I cannot open the Demo with this one… Really weird.

@VictorLerp, Can you please help with enabling Chaos in 4.25? It seems a lot of people are facing issues but no one is responding from Epic’s side

Just follow the documentation steps, enabling Chaos is very easy. :wink:
The problem is the demo.

I still has problems to run ChaosDestructionDemo, does that have a way to work?
my steps are
1, download the unreal engine from github, branch 4.25.0-release
2, follow the guide, modify UE4Editor.Target.cs and build UE4 with Chaos, https://docs.unrealengine.com/en-US/…iew/index.html
3, download ChaosDestructionDemo project and generate sln file with 4.25 engine
4, build and run, the problem happened with below



LogInit: Display: Running incorrect executable for target. Launching Unreal Projects/ChaosDestructionDemo/Binaries/Win64/ChaosDestructionDemoEditor.exe...
LogCore: Engine exit requested (reason: EngineExit() was called)
LogExit: Preparing to exit.


My UE4Editor.Target.cs looks like below



public UE4EditorTarget( TargetInfo Target ) : base(Target)
{
Type = TargetType.Editor;
BuildEnvironment = TargetBuildEnvironment.Unique;
bBuildAllModules = true;
ExtraModuleNames.Add("UE4Game");
bCompileChaos = true;
bUseChaos = true;
bOverrideBuildEnvironment = true;
}


I also tried to change BuildEnvironment = TargetBuildEnvironment.Shard, but this will make ChaosDestructionDemo as a zombie process.

Hi all~ I’m really new here… hope im doing this right…

I managed to get the chaos destruction demo built. However, whenever i try to enter debug, it throws an exception and i get “ChaosDestructionDemoEditor.exe has triggered a breakpoint. occurred” in my visual studio editor.on line 695: “ensureMsgf(false, TEXT(“Skipping non-manifold edge to face mapping.”));” of “TriangleMesh.cpp” and the debug stops working.

I use ‘//’ to comment away the line and try rebuilding and entering debug again. This time, it throws another exception but it’s on line 1007 : “if(ensureMsgf(DynamicCollection, TEXT(“No dynamic collection available for component %s during tick.”), *GetName()))” of “GeometryCollectionComponent.cpp”

I try using ‘//’ to comment away the above segment and managed to get the demo to run.

However, when I try and interact with the demo scene (by stepping on the buttons), none of the destruction elements seem to be working. 2. Fracture/Clustering and 3. Fields do nothing. 4. Niagara shows the particles falling but the pillar doesn’t get destroyed and 5. Gameplay has the “Detected!” lit up even though the box remains undestroyed.

Sidenote: When I close the niagara system editor, I get another exception on line 33 of “EventManager.cpp”: “checkf(EventID < EventContainers.Num(), TEXT(“Unregistering event Handler for an event ID that does not exist”));”

I don’t think I should be commenting away any lines but I don’t know how to get the demo to work… Can someone help me out?

Cheers!
Shawn

GitHub link appears to be dead, at least on my end.

Your GitHub is not linked with your Unreal Engine account
try this:

https://docs.unrealengine.com/en-US/…ine/index.html

I just got Chaos working on UE4.25.
The UnrealEngine-4.25.0-release.zip from github did not work for me (shader errors, LogMrMesh declared twice errors, etcs), I use git clone to get the most recent version.
This is my UE4Editor.Target.cs that build successfully:

// Copyright Epic Games, Inc. All Rights Reserved.
using UnrealBuildTool;
using System.Collections.Generic;
public class UE4EditorTarget : TargetRules
{
public UE4EditorTarget( TargetInfo Target ) : base(Target)
{
Type = TargetType.Editor;
//BuildEnvironment = TargetBuildEnvironment.Unique;
BuildEnvironment = TargetBuildEnvironment.Shared;
bBuildAllModules = true;
ExtraModuleNames.Add(“UE4Game”);
bCompileChaos = true;
bUseChaos = true;
bOverrideBuildEnvironment = true;
}
}

To run the Demo:
With the UE425+Chaos editor working, build a Blank Project and then copy the ChaosDestructionDemo423\Content folder to this new project Blank\Content folder, this is the easier way (that I found) to run the Demo without problems.

Update: It’s working on 4.25.1 too.

Using 4.25.1 from the launcher. Noticed under physics their is GC. Did it and it works. No fracture in modes??? In the compiled version the fracture is there.

I don’t think Chaos is active in the binary yet, you need the source from Git.

Just tried all the steps above for ue4 4.24.3 and 4.25.1 both times the chaos demo fails, it won’t let me enter the last part with the building says something about a cache, tried removing the barrier but nothing happens to the second building. Can someone just post a video. My specs are a gtx 1060 6gb i7 16gb ram.

I successfully built 4.25.1 and the plugin is “working”. The problem is that even a small box fractured in 20 pieces literally destroy fps to near 5-10 until the box is completely broken, plus, even other objects are completely bugged and start moving on the floor with no reason at all as if they were pieces of ice on a floor completely covered in oil. This was supposed to be a significant improvement from previous version and it ended up being a tremendous joke considerning that all this crazy things wasn’t happening with 4.24. And they call it “High performance physics”. My willing to learn this engine is decreasing with each release.

Man can you even see how bad and unacceptable the performance are about that? That crazy fps drop wasn’t there in the previous version. This is insane, I even suppose that depending on your pc and the number of chunks the engine would crash…

Has Epic said anything about releasing more content using Chaos? While the example demo is nice, it only really shows how things are built, and too few example of actual interactive objects, besides a column and a building.

Is there any content that Epic is working on to be released (what about that demo with the robots destroying the city?), or anything by the community to dissect?