How to enable Chaos

So, the GitHub link points us to 4.22.3 not 4.23. Which one is the correct one?

I did a simple “linear regression analysis” for 4.25. Did not control all variables. I will be about 150 by then(ha,ha). I am getting good at compiling the source.(P3-P8). What I really would like is the content examples that has Chaos. Oakman had it in the video. Put the project in P9. I get the CubeStack created then the GeoCollection. Then cannot do the next step. Has anyone that does not work for Epic accomplished this. Please do a video. Use OBS it is free.

@theProfessor Have you enabled the Fields plugin?

@theProfessor The Content Examples project is separate and not found at GitHub, which is only the engine code. The Content Examples is found at the Learn tab at Epic’s Launcher (you can see the latest one there up to UE4.22). Once the UE4.23 releases the project will receive an update marking it as 4.23 compatible and the examples with Chaos will be there, not in preview unfortunately.

Yes, I have enabled the Fields system.

@NilsonLima @theProfessor It will not be part of the content example project. You’ll be able to download a specific Chaos example project from the launcher under the Learn tab.

Interesting… probably the best since the feature is quite big and God knows we need more complex and compelling examples. I wish we could have something similar for Niagara.

Has anyone already run into this problem? If so can someone please point me to the solution in the thread?
I have tried following ALL steps in this thread 3 times but I can not seem to generate the project files needed to run from VS.
Each time I try i get this error.

Seems like its missing certain files? I have also updated my VS 2017 already btw. Should I try with 2019?

I have tried following all of the steps 3 times now and I still can not get past the generation of the project files. Not sure what I am doing wrong.
If someone has already resolved this can you please point me to the post with the solution?
It looks like I might be missing certain file that are needed? I have installed github 4.23-preview 8 and have the latest VS 2017 installed as well. I am so close yet so far! :stuck_out_tongue:
Any help would be greatly appreciated.

@FX-R080T Could you enter your VS2017 installer and show which modules you installed along with it? A single picture will do it. There are certain modules which are necessary and might be missing, which will prevent the build to be successful.

@NilsonLima Let me know if you need multiple shots of the list on the left.


@FX-R080T I can’t see if Game Development with C++ is selected, you can see it in the first tab called “Workloads” and make sure everything there is selected, it seems the only thing missing, if not, there might be any Windows Update, which is the latest Windows Update you installed?

So nobody knows the answer? Like with a projectile, field activates only when hitting a geometry collection?

Has anyone other than employees of Epic been able to use this video to get Chaos to work. Oakman is using the content examples to help. I can’t get past the CubeStack. Will try again today.

Where do you have a problem?

@NilsonLima I went ahead and re-installed VS 2017 with all relevant modules included. I also updated my windows 7 with the latest update which it did need.
But never the less after all that it still will not create the project files I need and with the same error message as before.

I am currently installing VS 2019 with all modules included. Hoping that will fix it but I am beginning to suspect that this is due to me running on Windows 7. Has anyone out there had any success setting up the project on Windowns 7?

Thanks again! :slight_smile:

He’s using a couple of assets from the content examples, but the logic and setup is done from scratch during the first portion of the stream. What are you having issues with?

Possibly with the anchor. Here is the BP. When I shoot the projectile does not fracture.

I don’t think you should use “Add Field” in Construction Script.

Here’s my blueprint for a strain field from the Livestream:


I couldn’t generate hit or overlap results from a projectile to geometry collection.