How to enable Chaos

Anybody know howto generate hit or overlap results with geometry collections? They seem to respond only to fields. And for example I can’t make any object stand above a geometry collection.

I downloaded preview 7 from the launcher, I could see all the following plugins and enabled them

  • ChaosEditor
  • Planar Cut
  • Editable Mesh
  • Geometry

Restarted the editor

I can’t seem to get the fracture editor in the modes tab. I guess it only works with the Github release branch code you compile yourself then?

EDIT: Looks like Victor already answered a similar question…

“You’ll have to compile the engine from GitHub to use Chaos until it’s out of Early Access, which will take a couple of engine versions.”

Not sure why we can see / enable the plugins in preview though.

Good question. Would like to know the same. @VictorLerp

I am having the same problem when I follow the instructions here. This is my UE4Editor.Target.cs:

using UnrealBuildTool;
using System.Collections.Generic;

public class UE4EditorTarget : TargetRules
    public UE4EditorTarget( TargetInfo Target ) : base(Target)
        Type = TargetType.Editor;
        bCompileChaos = true;
        BuildEnvironment = TargetBuildEnvironment.Unique;
        bBuildAllModules = true;


Once compiled, when I start UE4Editor.exe the following occurs. The error is always the same - highlighted in bold. (I’ve been trying to follow this thread and make this work since preview 4). Maybe its just best to wait for final release.

Fatal error: [File:C:/Users/max/Documents/GitHub/UnrealEngine/423/Engine/Source/Runtime/RenderCore/Private/RenderingThread.cpp] [Line: 836]
Rendering thread exception:
**Assertion failed: !bInitializedSerializationHistory [File:C:/Users/max/Documents/GitHub/UnrealEngine/423/Engine/Source/Runtime/RenderCore/Private/Shader.cpp] [Line: 168]**
Shader type was loaded after engine init, use ELoadingPhase::PostConfigInit on your module to cause it to load earlier.

Unhandled Exception: EXCEPTION_ACCESS_VIOLATION writing address 0x5327cde8

0x00007ff9e27d5eb7 UE4Editor-RenderCore.dll!FRenderResource::InitResource() [C:\Users\max\Documents\GitHub\UnrealEngine\423\Engine\Source\Runtime\RenderCore\Private\RenderResource.cpp:82]
0x00007ff9e28376ab UE4Editor-RenderCore.dll!TGraphTask<TEnqueueUniqueRenderCommandType<`BeginInitResource'::`2'::InitCommandName,<lambda_ca51434da6012349da95a9abb2880eb9> > >::ExecuteTask() [C:\Users\max\Documents\GitHub\UnrealEngine\423\Engine\Source\Runtime\Core\Public\Async\TaskGraphInterfaces.h:847]
0x00007ff9c2255465 UE4Editor-Core.dll!FNamedTaskThread::ProcessTasksNamedThread() [C:\Users\max\Documents\GitHub\UnrealEngine\423\Engine\Source\Runtime\Core\Private\Async\TaskGraph.cpp:686]
0x00007ff9c2255813 UE4Editor-Core.dll!FNamedTaskThread::ProcessTasksUntilQuit() [C:\Users\max\Documents\GitHub\UnrealEngine\423\Engine\Source\Runtime\Core\Private\Async\TaskGraph.cpp:583]
0x00007ff9e286fd6b UE4Editor-RenderCore.dll!RenderingThreadMain() [C:\Users\max\Documents\GitHub\UnrealEngine\423\Engine\Source\Runtime\RenderCore\Private\RenderingThread.cpp:340]
0x00007ff9e287834e UE4Editor-RenderCore.dll!FRenderingThread::Run() [C:\Users\max\Documents\GitHub\UnrealEngine\423\Engine\Source\Runtime\RenderCore\Private\RenderingThread.cpp:471]
0x00007ff9c26a863f UE4Editor-Core.dll!FRunnableThreadWin::Run() [C:\Users\max\Documents\GitHub\UnrealEngine\423\Engine\Source\Runtime\Core\Private\Windows\WindowsRunnableThread.cpp:96]
0x00007ff9c269ec11 UE4Editor-Core.dll!FRunnableThreadWin::GuardedRun() [C:\Users\max\Documents\GitHub\UnrealEngine\423\Engine\Source\Runtime\Core\Private\Windows\WindowsRunnableThread.cpp:53]
0x00007ffa32f57974 KERNEL32.DLL!UnknownFunction ]
0x00007ffa3569a271 ntdll.dll!UnknownFunction ]

You should do:

public class UE4EditorTarget : TargetRules
public UE4EditorTarget( TargetInfo Target ) : base(Target)
Type = TargetType.Editor;
BuildEnvironment = TargetBuildEnvironment.Shared;
bBuildAllModules = true;

bCompileChaos = true;


The difference is: “TargetBuildEnvironment.Shared”

Still no fracture editor in P8.

Unless I misread awhile back in this thread, Chaos will not be available via the launcher in 4.23. You must compile from source to use it until it’s officially released in a later version. Don’t quote me on this, though. :wink:

You are absolutely right. When Chaos comes out of its experimental state it will be part of the launcher. Until then you will always have to compile the version to be able to use it.

I would definitely expect to need to compile it in 4.24 and 4.25, too.

So, the GitHub link points us to 4.22.3 not 4.23. Which one is the correct one?

I did a simple “linear regression analysis” for 4.25. Did not control all variables. I will be about 150 by then(ha,ha). I am getting good at compiling the source.(P3-P8). What I really would like is the content examples that has Chaos. Oakman had it in the video. Put the project in P9. I get the CubeStack created then the GeoCollection. Then cannot do the next step. Has anyone that does not work for Epic accomplished this. Please do a video. Use OBS it is free.

@theProfessor Have you enabled the Fields plugin?

@theProfessor The Content Examples project is separate and not found at GitHub, which is only the engine code. The Content Examples is found at the Learn tab at Epic’s Launcher (you can see the latest one there up to UE4.22). Once the UE4.23 releases the project will receive an update marking it as 4.23 compatible and the examples with Chaos will be there, not in preview unfortunately.

Yes, I have enabled the Fields system.

@NilsonLima @theProfessor It will not be part of the content example project. You’ll be able to download a specific Chaos example project from the launcher under the Learn tab.

Interesting… probably the best since the feature is quite big and God knows we need more complex and compelling examples. I wish we could have something similar for Niagara.

Has anyone already run into this problem? If so can someone please point me to the solution in the thread?
I have tried following ALL steps in this thread 3 times but I can not seem to generate the project files needed to run from VS.
Each time I try i get this error.

Seems like its missing certain files? I have also updated my VS 2017 already btw. Should I try with 2019?

I have tried following all of the steps 3 times now and I still can not get past the generation of the project files. Not sure what I am doing wrong.
If someone has already resolved this can you please point me to the post with the solution?
It looks like I might be missing certain file that are needed? I have installed github 4.23-preview 8 and have the latest VS 2017 installed as well. I am so close yet so far! :stuck_out_tongue:
Any help would be greatly appreciated.

@FX-R080T Could you enter your VS2017 installer and show which modules you installed along with it? A single picture will do it. There are certain modules which are necessary and might be missing, which will prevent the build to be successful.

@NilsonLima Let me know if you need multiple shots of the list on the left.


@FX-R080T I can’t see if Game Development with C++ is selected, you can see it in the first tab called “Workloads” and make sure everything there is selected, it seems the only thing missing, if not, there might be any Windows Update, which is the latest Windows Update you installed?