Download

How to disable Indirect Lighting Cache for Instances?

I’m trying to disable any influence of the Indirect Lighting Cache on some Hierarchical Instanced Static Meshes, but can’t figure out how.

If I use the same mesh as a normal static mesh in the scene, I can set Lighting->Indirect Lighting Cache Quality to ‘ILCQ Off’ and it disables it as I would expect. But if I try to set the same setting on the Hierarchical Instanced Static Mesh Component, it does nothing.

Here’s what it looks like:

The tree on the left is a normal static mesh with ILCQ turned off, the tree on the right is an Hierarchical Instanced Static Mesh with ILCQ turned off. As you can see, it’s still receiving lighting information from the Indirect Lighting Cache.

Any ideas how I can fix this, and eliminate all lighting influence from the HISM?

That’s probably a bug they’ll need to fix, but I have to say that kind of looks cool.