Download

How to avoid smart indentation after Unreal decorations (UPROPERTY, GENERATED_USTRUCT

Hi,

I want to know if there is a way to tell vs2013 to stop messing with indentation after I use the unreal engine macros.

I hate to have to re-indent after I click enter after UPROPERTY or GENERATED_STRUCT_BODY

is there a simple way to avoid this indenting ?

ps. I do not want to disable all auto-indenting, only for these unreal macros !

It’s a bug in visual studio as far as I can tell. The only work around we could have is to put a ; after the macro. UHT would need to be less argumentative though.