How do I set a navmesh tolerance so my actor doesn't walk on top of the target object?

I want a big obeject, like a tank, to approach another big object on a navmesh, like a building. the trouble is when I tell the tank to move there it sits right on the building. How to a set up the tank so the navmesh is aware of it’s perimeter and doesn’t move it’s origin onto the location?

can you upload a screenshot from your blueprint ?

There’s nothing relevant in it, I simply grab a point from the navmesh using the random point node, and increment an object’s location. It’s not usual I know because my ‘actor’ is not a nav mesh agent per-se. I’d be interested to know if there are functions I can query to achieve what I want in this way though. It’s certainly an edge case.

You have a setting in the “Move To” node in your Behavior Tree which sets the tolerance. So when it is within X units it will act like it reached the destination and do whatever.

You could call different “Move To” nodes depending on how far this tolerance is or set it in your Task blueprints as you need to adapt it for specific objects the character should move to.