Download

How do I debug an obscure bug?

I was following a few different tutorials and I went on my own and did things. Of course, I could revert back to a previous version but that would defeat the purpose of this question. How can I debug a bug where I’m not sure from where it’s originating?

Situation:
I’m placing these objects on the ground but only one object can be placed, no other object can be placed after. It worked fine for a while and multiple objects could be placed. I assumed it would be a boolean that was acting up but it wasn’t. I also thought maybe the game mode was being changed weirdly and my left mouse click wasn’t working because of it. It wasn’t that either. So now I need to trace everything that is being changed at the moment that I place that actor on screen.

Is this possible to do?

There is no one stop solution for tracing this kind of thing. The main strategy to take is:

  1. Simplify

  2. Don’t assume

  3. Test

So cut it right down to the bare essentials. What’s the minimum you need to test this? Debug with print rather than debugger ( it’s a bit flakey ). Be methodical.

Thank you for your response. That’s a shame that there’s no visual debugger in that sense, it would be nice to press an F key and a list of all the active variables would appear on-screen or something. That’s okay though, I’m trying to figure this out, haven’t been able to all day and I did try before. Usually when something doesn’t work and the logic is sound it’s because either it’s a variable / reference issue or there’s fog of war over the issue that I keep passing by.

I’m going with the variable or reference issue. Something is either not being exposed or it’s being exposed when it shouldn’t be. I’ve been comparing old blueprints that work and everything is identical so I don’t get it. I kept it simple, removed the sequences that aren’t needed and well, it’s weird. This is why I preferred to code things, at least you could see the code difference and easily debug things. I want to like blueprints but learning how to work with them is a whole different game. :confused:

Edit: The issues pertains to the click / touch event. Once the object is placed, it no longer can left click but right clicking on it to open a context menu or navigating the UI still works fine. I can attest to this because I changed the keybind to “keyboard O” just to see and it worked fine pressing it. o.O