How can i make an invisible lpv emmissive light caster.

I want to light my scene with meshes that have emissive materials applied (I am using Light propagation volume realtime GI), however the lights themselves must not be visible, or cast any shadows.
How can this be done?

After much trial and error, I found a hacky method of doing it, which is to check: “hidden shadow”, and “dynamic inset shadow”, and uncheck: “Visible” in object render settings.
But I dont know why “dynamic inset shadow” removes the object’s shadow casting. why?