How can I kepp snow particles ot of my building ?

Hey there I used the P_SnowFlare Particle system from the Particle Cave demo to create snow in my Level. But how can I make that the snow doesnt fly through wall and I doesnt see the snow particles in buildings ?

Take a look at the collision module from cascade: Collision Modules | Unreal Engine Documentation :slight_smile:

But they are GPU sprites andthere I only have Collision (Scene Depth) and if I play around with the settings a bit some of the Particles gets blocked my Walls but some fly through so not every particle gets blocked. Is there any fix for that ?

The only fix for that is not to use gpu particles I’m afraid.