how can I get UE 5.0.2 to work?

Hi, so i just got UE5 installed a few days ago and I cant get it to launch, i saw that in the system requirements it says that it needs the latest mac os (thing that i do have) and xcode 12.4 but that version of xcode is not compatible with my computer and I do not really know what to do, im about to start university in a few months and most of my7 homework needs to be done in UE5.