Horrible static lighting?

Looks like your lightmap density is too low.
On your viewport settings (top left of the 3D viewport), where it says lit click it and then go to Optimization View modes, then click on light maps density.
This will switch the view of the viewport and show you something like this:

I’m betting your scene will be displayed mostly blue, this means the lightmap density is too low for your assets (should be displayed green).
You can fix that by either going into your mesh settings (in the content browser double click your static mesh) and under lightning you can set the lightmap density for that particular mesh (every copy of that mesh in the map will now have that density). Alternatively you can set it on each mesh in the map by selecting it and going to the lightning settings and enabling “Override lightmap resolution”.

Hope this helps! make it a great day!

When i change my light from moveable to static i get this :

when i put it at moveable i get this (what i want) :