Horrendous level size (800+ MB)


I am working on the map with over 3k actors on it. Without lighting built, it weighted around 80 MB.
Now that I built lighting, as you can see it’s a different story:


What steps should be taken to reduce this size (by a huge margin, preferably)?

Does your map use fully dynamic lighting or baked lighting from static/stationary lights?

Some tips for both possibilities:

Fully dynamic lighting

Disable the use of lightmaps. Use “Force No-Precomputed Lighting” in the world settings to disable generating lightmaps. (See also here)

Baked Lighting

  • Make sure you have activated compressed lightmaps. Check this under “World Settings → Lightmass → Lightmass Settings → Compress Lightmaps”
  • Look at the lightmap density of your world (See here). A more detailed lightmap (red areas) requires more than necessary space to display correctly. You can adjust the lightmap resolution of a mesh either globally in the “Static Mesh Settings” or per placed mesh under “Lighting → Overridden Light Map Res”.
  • Reduce the lightmap resolution on placed meshes where the player is unlikely to look (borders of the map).
  • Disable lightmap generation for objects by settings their mobility to “Movable”. Note that this also changes how the objects behaves in other ways than lighting.
  • You can see the generated light and shadow maps under “World Settings → Lightmass → Lightmaps”. Every lightmap is (by default) a 1024x1024 texture. Reduce the lightmap resolution of your meshes so you require fewer of these textures.
  • Also note that lightmaps are generated in a low quality and high quality version. Different platforms use different maps (more here).
  • It seems mipmaps are generated for lightmaps. Maybe you can tweak these settings but I haven’t tried it (more here).