HMDDevice isn't recognizing the Vive

As of 4.18, I am not able to run, view, or preview my projects in the Vive headset. Upon further inspection, I found that the Get HMDDevice Name node is returning “FGoogleVRHMD” (only built-in plugins are being used). If I disable the Google VR plugin, then it returns “AppleARKit”. If I disable the ARKit plugin, then VR Preview becomes greyed out, and the node returns “None”. The problem also occurs in packaged builds, leaving them unable to recognize the Vive.

My Vive is set up properly, as near as I can tell, and it works perfectly fine on all projects in previous versions. I even tried making a blank new project using the VR Template, but found the same results. I also tried restarting the computer, deleting the Saved and Intermediate folders, and running all applicable programs (the editor, SteamVR, etc) as an Administrator, to no avail.

This makes it impossible to do any Vive development in 4.18.

I have the same issue in 4.18p3

This issue is still occurring in 4.18 Preview 4 as of 10/10/17.

Hello Matt_GrooveJones,

I was unable to reproduce this issue on our end. I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean blank project (not VR template)?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. Could you provide screen shots of any settings/blueprints that my be involved with this issue?
  1. Yes, this occurs even in a Blank new project. To falsify, my Vive works properly on every previous version of the engine, and I have tested going back and forth.
  2. With my Vive connected, I just launch the engine and create a new project. Once created, the “VR Preview” option underneath the ‘Play’ dropdown is greyed out and inaccessible. I’m not sure what other details I can provide, though I’ve attached some screenshots of the plugin settings.

My plugin settings are the same as previous projects where the Vive works perfectly, and I have no third-party plugins installed.

Please let me know what additional information I can provide to help isolate the cause of this. If it is actually something on my end, then I need to get it sorted as soon as possible.

2 cont.) As an additional point of testing, if you add a “Get HMDDevice Name” node to the level blueprint and hook up the output to a Print String log, the output reads “none”, as in the original post.

What version is your SteamVR? 1.5? or 1.48? I tested a VR project because of another “bug” in vr spectator mode with Preview 2 or 3 and it worked for me with the Vive. But I found that Steam VR 1.48 for example doesnt work at all with the Vive anymore. Although this is quite old too. But maybe that helsp and somehow, your steamVR version did not update. Anyway, Vive works for me, didnt test with preview4 yet though

That was absolutely it. I had 1.49, and it didn’t update because it was left open. Updating to 1.50 caused the Vive to start working again. Thank you!!