High reconstruction "processing failed: Unknown error / operation failed"


I’ve had quite a complex model processing for about a week and am getting the error 

Processing failed: Unknown error



using the cashed data the error repeats after about 200-400 seconds of processing (although sometimes with “processing failed: operation failed”). Ive tried rotating/ adjusting the reconstruction region with no joy. any ideas before i take the plunge and reprocess from scratch (all 572368 seconds).


Hard drives seem to have ample space, 

this is running on a duel socket dell r5500, 2x6 core x5680s @3.33, 48GB RAM, 1xGTX 1080ti.





Not sure if that helps but I remember somebody in the forum reporting about unexplainable crashes that turned out to be intersecting surfaces due to misalignment.

thanks Götz

I’m assuming, if the problem goes back to the alignment, it basically means starting from scratch as all the cashed stuff from the first time round will be irrelevant. I think rather than spending many man hours trying to fix this in the hope that it completes i might just start over and throw another week of computer time at it and hope for the best. 

Used to get these kind of problems all the time but not so much ow,  so every once in a while you just have to take it on the chin. Given the complexity of whats being calculated its not surprising it happens every now and then. 

Well, for one thing its only a speculation on my part. You would need to inspect the model for intersecting surfaces.

And resolving that would have to be done at the alignment level - I assume the week was spent on reconstructing a mesh?

What are you doing, if you don’t min me askin?

Yeah the week was spent reconstructing the mesh. 


Im making a animated dance installation for Sadler’s Wells in London. All the scenography is models which are being digitised using RC, with dancers to be chromakeyed in - if i ever get that far. Retrospectively it’s probably the most time-consuming way of creating such a thing but after almost 9 months of making models and digitising with 3-10 workstations I’m nearly onto the next part. 

workflow is here:



all of which is taking place in a very hot and noisy office:



Im a choreographer first and foremost so i’m looking forward to seeing the back end of all this model making and digitising:



needless to say the support on forums has been a massive help and made it possible to get this far so thanks to anyone thats helped. 

Wow, nice stuff. Awesome how realistic the model seems in the animation!

What kind of a huge setup is that in your office? And you say you are not mainly doing photogrammetry. Jealous!

I think you are the first one who I would say used too many images!  lol

How huge is that bit that you had processing for a week? I would seriously consider deactivating 4 out of 5 images (if you took as many images as in the video and screenshots. I would say that 100-200 should be plenty for that kind of object. You aren’t doing yourself a favor by having so many shots almost on the same spot either, that can lead to noise.

Anyway, the result is superb in any case.


I do a lot of filming and animation work (all dance based), so lights, cameras and computers are all used for that. and on top, most of those workstations are old and you can pic them up for quite cheap now a days. so for doing 3d stuff they’re very good and cheap to use as render nodes - although they are quite thirsty on electricity. 

Im getting a lot of photos because I’m trying capture these models with a macro lens and with the depth of field its difficult to get it all in at a scale which can capture the details. But its very interesting you say perhaps its would yield better results/less noise with less images. It certainly one of the most laborious and boring jobs to capture all these things. 

The big model that was processing for a week was the model of the tree. so there was a lot of obscured things form all the angles. 

thanks again 

just to add to this thread for anyone who might be stuck in the future. Had another problem on a similar spec machin. Saw the RAM was totally maxed out so I’ve swapped in some more dimms to increase the RAM and will report back if that made a difference. 

Hi Wilkie,

the RAM should definitely NOT be maxed out completely. Do you also observe massive use of virtual memory?

Similar observations have been made occasionally, but never so persistently.

I would encourage you to open a bug report on this - there might be a chance to pinpoint the problem since you observe it on different machines…

I think ram should help a bit. I found i would get further before it crashed.

maybe you have more photos than you need though.

I’ve had lots of these issues in the past, I’ve had plenty of 3 week+ processing time that end up with a crash.

the way i ended up dealing with the issue, was splitting the scene up into many reconstruction regions.

this got everything done, and I ended up finding a small part of the model that would have caused the issue.

which is generally something missed aligned. 

though you do get issue’s with splitting the file, and i would try to avoid that for esp for just a small model.

I’d go with dropping the amount of photos first. looks like you have more than enough. 

Yes, more memory is always better, but the point is that RC should be able to split everything up into smaller pieces, so it can handle it with what resources are provided. If the RAM maxes aout, it is either a problem with the dataset or a bug.

Chris, was that you who reported this detailed observation about crashes with intersecting surfaces on a model of a house with interior and exterior combined?

no I haven’t done any interior/exteriors of buildings.

I’ve been doing stupidly large things, like cities.

and it did seem that i was only have a very small part of it breaking it for the rest of it.

it was solved by me splitting it into a 100+ regions and working each out on their own.

and in the end i think i had problems with one of them.

it would have been nice to have some more automated way of doing it. but i did end up scripting parts of it.


Thanks for the advice guys. 

Just to update you (with glacial processing times its not that often we get to report back on what happened very soon)

As pointed out the Increase in memory didn’t seem to make any difference - same error. 

Moved the project and cash to another machine with a slightly higher spec:

duel socket dell r5500, 2x6 core x5690s @3.46, 96GB RAM, 1xGTX 1080ti.

the only other difference is this new machine is running window 10pro instead of 7pro

either way the reconstruction completed. I also notice in general that this machine running window 10 seems disproportionately faster than the windows 7 machines. so i don’t know if its got something to do with the OS.

i’ll take your advice onboard and try running some reconstructions with1/2 there images disabled see what kind of results and speeds that gives too.