Help with VR Time Dilation

I am trying to make a VR Shooting range where the entire scene goes into slow motion and the player remains at normal speed.
I have managed to get my entire scene to slow down by setting the the global time dilation to 0.1.

  • The problem I am trying to solve:

The problem is my gun is now moving is slow motion. I have tried setting the custom time dilation of my player pawn but it doesn’t fix the problem as my character (Gun movement in particular) is still slowed down while my look around speed is the only thing that remains at normal speed.

  • How I tried solving the problem:
    I tried fiddling with the event tick that updates the attached gun and I realized time dilation is probably not affecting the tick time of my player pawn. I have even tried using the advanced time plugin without any luck

How can I make it so my gun (player movement) isn’t affected by the global time dilation in VR?

Any help would be highly apricated! :slight_smile:


What do you mean the gun is affected by time dilation? The Gun Actor moving in the world or the shots of the gun?

If the gun is attached to the MotionControllerComponent, it should move with the controllers. I would assume the MotionControllerComponent movement not to be affected by time dilation.

Thanks for your response :slight_smile:
I mean the gun actor moving in the world.

Hm, can have a look tomorrow.

Thanks! :slight_smile:

console command “slomo” works as expected. VRHeadSet and MotionControllerComponents are not affected.

Ya that’s what I don’t understand my motion controller is at normal speed but when i am picking up a gun (Attaching it to the motion) Controller it slows down. Do you know how to get around that problem?

We have our controller visuals within a blueprint. The blueprint is created at runtime and attached to the MotionControllerComponent.

I think i figured the problem. Only global time dilation works when I try to use custom time dilation on any actor it doesn’t work do you know why the custom time dilation isn’t working. (I have tried on a brand new 3d game project and it was working fine)

What is global and custom for you? Which functions/commands do you use?

here are the two functions I tried, I also used a custom global time dilation function with a plugin but it didn’t work either.

That is just one function. The bottom thing is just a variable of your current blueprint. try ExecuteConsoleCommand node with “slomo 0.1”. You can also go faster with “slomo 2” or set back to normal with “slomo 1”