Download

Help with target point following character

Every time it gets to the point, it pops up. Can someone help me fix this? The link is to a video of the issue.

Have you tried breaking the location vector of the TargetPoint1’s actor location and forcing the Z axis to be 0?

I have, but what nodes do you recommend me putting that in between? Where it gets the location I broke it into XYZ, changed it to the same Z coordinate that it needs to start and end at (I believe something like 168), converted it back to a location vector, and fed it into the move to location. Is there something I did wrong or that I should do instead?

Yes, not to zero but to the Z value it should start and end at (I believe 168). If I made it zero it would fall through the floor. The problem is not where it ends up, but where it starts for some reason. It always ends in the correct place, but pops up immediately on the Z axis as soon as the code is run to make it move to the next point. Any suggestions?

Try taking the component you are using the ‘Move Component To’ node for and locking the position on the z axis. Look at my image for reference. This is the detail panel that pertains to the component you are dealing with. Let me know if that helps!

I checked the Z box on “lock position”, and it still doesn’t seem to do anything to help. Any other suggestions? I have no idea what the problem is because my code never says to change the position of the Z axis, as both Char1 and all of the target points are at 168.

If you could get other people to help by the way, that would be great. I need this fixed by the end of the day tomorrow to meet my personal goal. So suggest as many options as you can think of please.

I PM’d you. If I solve i’ll post in here and via pm.