Download

Help with FPS Player please....

So I followed the 3rd Person Blueprint series to the letter up to the input and mouse blueprint. The only thing I changed was the position of the camera. Everything works except for the mouse input. I can’t turn or look up with the mouse, I can with the mobile controllers but not the mouse. Anybody have any ideas why this is the case or how to fix it?

Could you post a picture of your component tab + your mouse setup in the char bp? :slight_smile:

Here you go.

Have you enabled “use pawn control roation” in your camera properties?

Yes. I tried it both with and without that setting. Still no turn.

Even when you remove the hierarchy between the mesh and the camera?

@fighter5347 - What do you mean? Should the camera not be parented to the body? Am I that much of a *****? LOL

Ok forget what I said :stuck_out_tongue: I just tried it out and somehow it should work when you enable “use pawn control roation”

Here is a little video:

Also make sure that you have correctly set up the input axis turn and look up -> project settings - input - axis :slight_smile:

1de32eae0b32eb01775c9e7d9ae7b8fbda6ff05e.jpeg

That’s Exactly what I have, although I do not have ‘Look Up Rate’ mapped to anything.

Hmm, really strange. Could you probably post me the link to the tutorials (e.g video 1 to 5 -> so the ones that you have followed/the important ones) so that I can test it :slight_smile:

Edit:
Ok, currently following the tutorial series ^^

Edit:
Hmm, somehow you have made a tiny mistakes somewhere…in my case it works perfectly :slight_smile: When you send me your character bp, I can take a look at it

How do I send you that? LOL

Just upload it to gdrive, dropbox,… :slight_smile:

OK but fo you want an image or the entire file? If you want an image I can do that easily but I have no idea how to export the BluePrint file.

You send your entire project file to gdrive.

OK. I’m having some problems with the upload right now. I’ll try it again tonight and let you know what’s what. Thanks for the help.

Dont upload the entire project → just go to your project folder - content - … - there you should see your character bp file. Now just upload it :slight_smile:

Hmm, ok, it seems like your menu is somehow causing this, because in my case it works :slight_smile: