Download

Help with changing movement modes for 2D top town game.

Hey there,

Firstly, allow me to clarify I am still pretty new to the Unreal Engine so please excuse if there is a simple solution to my problem and I was unable to find it.

To explain, currently I am working on a 2D Top Down personal project (think Pokemon) and I have interactions between the player and NPCs. However, when the player is interacting with the NPC (dialogue boxes and basic dialogue system) I want to prevent them from being able to move so not to cause issues with widgets. I have tried disable movement, however, I couldn’t find a solution for trying to enable the movement again. Disable input is not an option as I have an the action key to run through the NPC dialogue, which won’t work otherwise.

I was trying to use Set Movement Mode, which sorts half of the problem (stops the character from moving) BUT I cannot return him to being able to move once the interaction has finished. The default Movement Mode is set to flying so that the character sprite can move along the X and Z axis, when the player interacts I tried setting it to none and then when the interactions end set it back to flying. However, upon ending any of the NPC interactions my character can rotate directions and flipbooks but he cannot move in any direction. Just before posting this I tried playing with a boolean for the collision to see if that was causing issues but no luck so far.

Can anybody help me out here?

(screenshots of blueprints and game attached for reference)

Thanks Everybody,
Phil