Download

Help , Upgraded from 4.22.1 to 4.22.2 and raytrace is not working anymore

Hey Guys ,

So after upgrading to 4.22.2 the engine crashes every time i open a project with a rytrace option On , i can start a new project with no raytrace , and once i enable raytrace and restart the engine through the shortcut that was adjusted with ( -dx12 ) in the properties the engine crashes ,

is 4.22.2 have a different raytrace enable steps then the older versions ,

What should i do to solve this ?

Thanks

You can try this:

  • Open your config file for DefaultEngine.ini in your config folder and delete the following lines in that file.

  • r.SkinCache.CompileShaders=True

  • r.RayTracing=True

  • DefaultGraphicsRHI=DefaultGraphicsRHI_DX12 (if you don’t see this one, don’t worry. It’s only if you set the RHI DX12 in the Project Settings instead of using the shortcut with the command line -dx12)

Now just re-open your project and re-enable Ray Tracing in the project (which enables compute skin cache too) and in the Project Settings be sure to set the RHI default to DX12 (see the Ray Tracing documentation if you’re not sure about how to do this).

It seems like maybe the settings got into a bad state or whatever. Hopefully this should get it up and working for you again. The steps have not changed from previous versions for enabling RT features.

Thanks , but ive tried it and it didnt work the same thing crashes again and again

So i have installed a fresh copy of 1809 windows 10 thinking that after formatting my system things can go clear , but still am getting unreal crash after restarting and enabling raytrace even that my card is 2070 and things always run smooth but after that latest update nothing is happening but crash every time i enable raytrace

Ok finally i have solved it , basically i removed the Nvidia DCH and let nvidia experince pick the latest update and also did a all the windows update and it worked