Download

[HELP] Perfect Mesh UV's in Blender2.79b but horrible in UE4.19

Hello everyone,

Currently we are developing a horror game, for this we have modeled an “flat” and realized the UV for the latter. Using a ColorNumbersGrid texture we can see that the result is just perfect in Blender:


Best picture size : https://drive.google.com/file/d/1JoWTLkItoLe8KywEh2m8U_Yv2U50tW14/view?usp=sharing

But after importing the mesh into Unreal Engine the material applied to the mesh seems to be distorted because of the UVs :frowning: :


Original picture size : https://drive.google.com/file/d/175cVEMUu2n6Gp50dH0kgkY3hs_QLfWWp/view?usp=sharing

If anyone would have an idea of ​​where it might come from, it would be very great please… :slight_smile:

It looks like unique UVs for the entire mesh. There’s a setting in the static mesh editor window called “use full precision UVs”, you should enable it for such intricate UVs.

I managed to solve this problem! Just enlarge the scale of UVs in Blender and after the mesh import in Unreal Engine you have to go to the static mesh editor window and enable “use full precision UVs”. Thanks to Manoel.Neto ! :slight_smile: