Download

help needed, root motion not working

hello, i’m working on a survival game and i’m using some root motion animations.

i have setup a place holder player and there all the animation, including the root motions ones are working fine.

now i bought a character from the market place, it came with its blueprint and i’m migrating my functions from my place holder player to my bought character, after some work i was ready to test the first root motion animation, my surprise, root motion is not working.

i tried and checked everything on the animation, on the player blueprint and the animation blueprint, it has checked root motion on the animation clip, also has root motion from everything in the animation blueprint, i really don’t know why is not working.

also when i use the root motion animation, the player stays in the same position, i checked on the web and the forums for root motion problems and the common issue is the player moving but it returns to the start point.

i tried to compare and check the animation blueprints and the blueprint from the place holder and the new character but i didn’t notice any differences.

maybe i forgot to check/uncheck something in the player’s blueprint or in the player’s capsule.

please i need a little help, thanks in advance.

i think i found the reason of my broken root motion.

the model that i bought from marketplace has two skeletal mesh components on it’s blueprint, and the mesh is working on the one that is not inherited from the blueprint class, i think that is the problem, i have attached a picture that shows the blueprint components.

is there a way to make the capsule follow the second skeletal mesh component and ignore the inherited one ?

thanks in advance for all the help.