Download

Has anyone else experienced this *Two different asset packs* Simple confusion!

Hey there all!

My problem is I have bought two different asset packs from Marketplace. One is a weapon component system and the other is the Complete RPG tool. If I setup Gamemode, Default Pawn Class and player controller for one asset pack I CANNOT then use the function PLAYABLE ACTIONS from the other asset pack as each asset pack requires you two use their character blueprint inconjuction with their game modes.

I have tried transfering everything from the RPG TOOLKIT Character blueprint to the Weapon component system Character Blueprint and set the weapon system as my game mode as wellas default pawn and player controller and now the functions of the RPG tollkit don’t work properly. Can any of you kind people please throw me a bone and help me as I am truley puzzled by this!

Basically my question is, "How do I set it up so I can use ALL functions from RPG Toolkit blueprint character and Weapon System Blueprint character?

I would be eternally grateful to whoever can help me solve this but I ain’t pinning my hopes on getting help here as this is my 20th question on these forums and no one ever helps me but hey ho you never know. This time might but the time someone takes mercy on me and helps! Not bitchin’ just saying! I sometimes feel like I’m hated on these forums or something! LOL!

Cheers and stay safe all!

Best wishes, Digital Theory!

I guess my question is “How do I merge two different character blueprints?”

Can no one help me? This is a basic enough question! Why does no one ever help me> I know no one is obliged to help me but just one time when I need it the most would be nice! JESUS!!!

The problem with this, is there is no easy answer. Most of the time, when people buy assets they already are part way through their project so they’ve already setup their own game mode, character etc. Some assets which use these will sometimes have documentation on how to migrate it into your own project and how to modify your own character and game mode to get it to work with the asset instead of using their character and game mode. This would obviously be my starting point if such documentation exists, or even perhaps email the creators of the assets. The process is going to be different for different assets so getting an exact answer is not going to be easy unless someone has done the exact same thing before.

I know I didn’t really help, but I would try and email the creators of the assets and see if they can give you some ideas.

Questions are going unanswered because the forums are dead dude. Why? Best guess, because Epic abandoned the forums back in 2017 Discord or for Enterprise UDN, is where its at. Read some other threads and you’ll understand this.

Back to topic. What you’re highlighting is one of the biggest issues with BP that all devs have to go through. Its one of the major drawbacks of using the Marketplace versus making everything yourself, as there are no super easy solutions. Things are made worse by devs creating lots of superfluous functions / macros that don’t really add anything or don’t offer proper encapsulation / re-usability.

That’s why I tend to encourage people to learn by taking projects apart rather than learning from YouTube / wikis / blogs, as you ‘earn’ these skills pretty quickly. The only quick solution which won’t work for every use case is to have a Character-mode toggle system. Say you need weapons but don’t need them all the time, then you can ‘house’ those in a Character-Weapons pawn and toggle to that whenever its needed (hide the parent pawn / disable collision / disable tick-> unhide Weapons-Character / enable collision / enable tick). You then add code to teleport the ‘twin’ pawn and some camera code to match POV. If the character enters / exits vehicles you also need to cache or re-create the ‘twin’…

OK! thx you guys. I guess that makes Marketplace about as much use as a dildo in a convent! =-/

TIP:

Try Bruno Xavier’s Property Transfer Tool… :wink:

Yeah I tried that but the only thing is it does not copy the Construction scripts and it has a whole bunch of them not tied to any functions as far as I can see! =-/