Download

Has 4.11 changed how UMG hover events are handled?

I had a project in 4.10 that had some issues, so I upgraded to 4.11 and began recreating it in there. I noticed in 4.11, however, that my button hover event (simple change color on hover) is not working. I tried enabling both touch and mouse over events in the player controller bp, but it did nothing. In 4.10, this works just fine. Have they changed how these events are enabled in 4.11? If so, can someone help me fix this?

Current 4.11 bug with window focus when ShowMouseCursor is true. Click once and it should work.

Yeah, I knew about the show mouse cursor bug. What I am having an issue with is when I hover over a button in my umg, I want it to change color. It did this in the 4.10 version, but can’t seem to get it working in 4.11.

Button -> Appearance -> Style -> Hovered -> Adjust Tint (or Image) as required.

(Did you forget to set your PlayerController in the GameMode, or forget to set the default GameMode?)

I raised an issue in Answerhub about this same (if not similar) issue. It came back as a setup issue apparently but there was a change since 4.10 - 4.11 and there still appears to be some kind of underlying issue, which could be the show mouse cursor bug.

https://answers.unrealengine.com/questions/409186/bug-umg-onmouseenter-does-not-trigger-when-mouse-i.html

I found a way to get it working correctly again by setting “Input Mode Game and UI” (Lock Mouse = False, Hide Mouse = False). Hope this fixes it for you aswell.

No, I did not forget to set the default player controller or default game mode. And the Button>Appearance>Style>Hovered>Tint is set to a different color as well. All of that is set up correctly.

Prototype, thanks for the tip on the input mode game and UI. i will try that.

Setting the input mode to game and UI did NOT fix the issues.

I’ve given up with my menu for now, 4.11 totally broke all my interactions, especially hover. I was previously calling it and navigating with the controller. They really messed it up.

Both the Appearance OnHover, and the OnHover Event node work correctly for me. http://i.imgur.com/AcqVeJZ.gifv (OnHover event not shown).

Did you convert a project to 4.11?

I originally had tried converting it from 4.10, but the crash issues I was having with the 4.10 version carried over into the 4.11 version, so I just began recreating it in 4.11 instead. My partner is using a version of 4.11 prior to the 11.2 update, and his hovers still work. It had to have been something in the 11.2 update that messed up the hovers. I tried setting up a hover event node as well. Did not fix it.

Was the version in this video prior to the 11.2 update?

It was a 4.11 created project in 4.11.2, I just made it right before posting.

If you did not figure this out yet, it occured to the me that you should check the Project Settings -> Input -> Viewport Capture. There are settings there that will prevent mouse capture.