GTX 970: Translating performance to what I would see on a Gear VR...

Assuming that I am within the guidlines of ‘Gear VR best Practices’ (drawcalls, poly count, max 2k textures, memory usage, all of these within range) running on a GTX 970, 1920x1080-FXAA aniti-aliasing, what frame rate should I be hitting for it to translate to a solid 60fps on a Gear VR (I’m assuming a galaxy S5/S6 is capped at 60fps). 100,200,300 fps?

I’m trying to find a quick & simple way to see if my build is workable on a Gear VR.

I’ve been using UE 4.9.2, a DK2, Oculus runtime 0.7.0, and trying to hit a consistent 75 fps at HMD SP 180, but it seems to me that a desktop build at 1920x1080, and targeting a frame rate that would translate to a Gear VR stetup would be simpler. Less variables.

So if anyone out there has a 970 and a Gear VR, and managed to create something in UE 4.9.2 that manages to hit a very consistent 60 fps, could you run a 64 bit desktop build, run it at 1920x1080, and let me know what FPS is being displayed?

It’s a lot to ask but I don’t have access to a Gear VR and I’d like to know if I’m in the ballpark…


…while I’m at it, can anyone with a Gear VR also tell me if spatialized audio is supported on the device?

120 FPS - but that could the max limitation of my monitor - I don’t think that’s a good way to ball park it though as mobile gpus might handle certain UE4 features differently from the 970gtx. The best way to test if you don’t have a gearvr is to run on an equivalent mobile and see what FPS you get there :wink: You need to be always at the mobile max of 60 since the scene will be rendered twice on the gearvr.

And no up until 4.10 UE4 still does not support spatialized audio on gearvr :frowning: very disappointing since Oculus say it is support with their SDK Epic just hasn’t added this very important feature yet :frowning:

Thanks Burger. Point taken…I am trying to stay away from what I read is unsupported on the Galaxy phones (unfortunately I use an iphone :frowning: ) Just as a side note, I’ve found that if I display [stat fps] in the play in editor window, I get 120 fps as well. If you preview it as a standalone game and [setres 1920x1080] do you still get 120fps? I’m getting 250/300 fps as a standalone preview vs 120 [PIE]. Ignore all of this if that’s what you’ve been doing all along :slight_smile:

thanks again

-Oh and my project settings/general for frame rate are below (max set to open via the pulldown menu)

ah ok in standalone game I seem to be getting about 370-460fps

Great thanx. Last one and I’ll stop bugging you. Are you setting the resolution to 1920x1080 using [setres 1920x1080] command via the console after it’s running? If so that’s some serious optimization…I can barely crack 300fps at 1920x1080 and I don’t know what else I can possibly do to increase it.)

If I just run it as standalone without changing the resolution, I get about the same numbers as you. So I’m hoping you didn’t, then there’s a chance my build will actually run on the Gear VR at 60fps :slight_smile: :slight_smile: :slight_smile:

If I turn of Smooth framerate i get the fps my system is able to perform in normal mode.
I’ve noticed that my fps is 2.5-3.0 times lower when i turn on oculus, maybe this will help.

Mind you I have a very weird model and using a Geforce 770 GTX 3gb.