GTX 760 85+ Degrees when in UE4 Editor, Suggestions?

I downloaded UE4 yesterday and have been periodically playing around with it. While I enjoy this immensely, my fan in my computer becomes extreme noisy. I downloaded a third-party program to check what my graphics card temperature was at, and it’s reporting 80-85 degrees Celsius while in the editor. I’m slightly afraid to continue using the editor (even though I still want to) out of fear of frying my graphics card.
Anyone have any suggestions as to what settings I could mess with or other various techniques I could do to help reduce the temperature but still effectively use the editor?

welcome to the forum:)

80-85 degree C is an ok temp, according to the specs it looks like that card can take temp’s up to 97 degrees C so I don’t think you need to worry unless it gets near its max. to reduce the temp you should first check your card for dirt/dust and make sure it has good air flow, another thing you could do is download one of the many app’s that let you control the fan speed to help you control the temp, you can also turn down the graphics in UE4’s scalability settings to reduce the workload on the card but then things wont look as good.

that’s all I can think of right now, hope that helps:)

GPUs and CPUs has termo protection systems, in case of dangerous overheat they should shut off before any damage is done. If you not overclocking and your cooling is not broken in anyway GPUs and CPUs should handle work on 100%, they are designed to handle that work, so software can’t really blow hardware just by doing heavy work.

It won’t burn out, but wouldn’t it shorten the lifespan if it runs at such a high temperature over an extended period?

I’m using a GTX 660 OC and my temps max out at 70-72 on stress with all graphics set to Epic. I’m using a custom fan profile though, you may want to look into doing that as the stock settings aren’t that optimized. If your card is an EVGA look into their Precision X software. It’s easy to use, and you can monitor your temperature and fan speed in the taskbar.

I always cap my framerate in the editor so my GPU doesn’t have to work quite as hard. Open the console (by default I think it’s always the key to the left of 1) and type “t.MaxFPS 60” (60 can be whatever number you like) and press enter. This doesn’t persist through editor restarts though so you’d need to do it every time you open the editor.

That’s odd, just tested with my Gigabyte GTX 760, and the highest temperature I saw was a split-second spike up to 69 C, which is normal. I’m running two external fans for ambient cooling, but in 30-35 C ambient it doesn’t help much.

What brand is your 760? I know a guy who has a Zotac 980 who’s had nothing but problems, so we can’t rule that out as an issue.

I had same problems few years back with ut3 editor. Try limiting fps or enabling vsync, unreal will get all power from card if its allowed to.

Turn off Real-time in the viewport(Top Left Menu), this will drastically reduce your GPU usage