Download

Grab bluebrint with motion controllers

Hello everyone,
I have a problem with grabbing objects in the default VR template, version 4.13 of the engine.

If you’ve ever tried the editor you know there are little white cubes that can be dragged with the motion controllers.
I’ve cloned these cubes, changed size and materiales, and the clones are still grabbable. I have even inserted a circle, configured it and it’s grabbable.

Now I’m trying to create a blueprint with a basic cube mesh and a light inside, a sort of “cube of light”. The results still produce a vibration when the motion controller collide with any instance of this blueprint, but the object per se isn’t grabbable.
I’ve configured the static mesh of the bp in the same way of the ones in the template, but this hasn’t helped.

So the question is: is possible to grab a blueprint by its root mesh?
And if yes, what I need to change in the configuration of the blueprint?

I’ll add some screenshot of the configuration to help. Thanks anyway, and forgive my english.

I was able to just use Add Component to add a point light to the StaticMeshComponent of an existing BP_PickupCube and it worked fine. I could pick it up and throw the light.