Google+ Permissions

Hello,
after we switched over our project to UE 4.13 we got some strange behavior on the login with Google Play Services.

After i get asked for an account to login with, i get another windows to allow additional Google+ permissions on reading my age and language, etc. (see Screenshot)

Our final AndroidManifest.xml permission settings look like the following:

[....]  
<!-- Requirements -->
  <uses-sdk android:minSdkVersion="15" android:targetSdkVersion="22" />
  <uses-feature android:glEsVersion="0x00020000" android:required="true" />
  <uses-permission android:name="android.permission.INTERNET" />
  <uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE" />
  <uses-permission android:name="android.permission.ACCESS_NETWORK_STATE" />
  <uses-permission android:name="android.permission.WAKE_LOCK" />
  <uses-permission android:name="com.android.vending.CHECK_LICENSE" />
  <uses-permission android:name="android.permission.ACCESS_WIFI_STATE" />
  <uses-permission android:name="com.android.vending.BILLING" />
</manifest>

These are the same we had with 4.12.

Thanks for help with this “issue”.

Kind regards,
Marcel

pyr0t0n,

So I pulled down Unreal Match 3 from the Play Store to verify that the same screen pops up. When I install the application, I get “Unreal Match 3 needs access to:” and it lists all that Unreal Match 3 needs access to and you accept it.

  • Do you see any differences in your AndroidManifest.xml from 4.12 to 4.13 in your project?
  • Did you upgrade to 4.13.1?
  • Are you using Binary or Source?

Thanks!

Hello Samantha,
i pulled down the Unreal Match 3 from play store too and yes it’s requiring the same G+ permissions as our app after the Update to 4.13.

That wasn’t a thing with 4.12.

  1. The AndroidManifest looks the same with 4.12.

  2. Yeah we upgraded to 4.13.1 but the same permissions are required.

  3. We use the Source Version.

Before 4.13 the user was logged in to Google Play Games and everything was fine, no additional permissions on G+ were needed to be accepted. This only shows up since we switched to 4.13.

I assume thats a (side) effect from

New: Added additional scope (plus.login) to Google Play Games builder. (Changelog for UE 4.13)

Is it possible to disable this additional scope?

Thanks for helping out.

Kind regards,
pyr0t0n.

In Android 6.0, permissions have changed from where you could choose “all or nothing” to a different structure where the prompt for each permission appears when downloading an app for the first time. So that would include Google+ profile, contacts, phone, etc.

Check your Google settings for the application and make sure there weren’t any extra security measures/privileges provided in your application profile.

Okay we will check our Google Settings, but i have to note that we did not make any changes to our App or Google Settings. We only have updated the engine from 4.12 to 4.13.

Did your Android version update? 6.0.0 + requires different prompts now.

We have this problems on Android Devices with Android Version 6.0.0+ but these devices had this version before we updated the engine. So thats not the problem.

In 4.13.1, Google Play Services was upgraded to 9.2 and is likely the cause to this prompt.

Okay, i think there is no way to suppress / disable this prmopt and get the functionality back which we had in 4.12?

Not that I’m aware of, it would be due to the update from Google Play Services.