Gnereating UV set in Static mesh editor

It seems that the ability to generate unique UV set has been removed from the editor, is there a way to re-enable it or did i break something?

Thanks guys.

Hi GBrodeur,

I’m assuming you’re using the latest engine version 4.5.x since you’re not seeing the it in it’s previous location under the menu bar > window > Generate UVs.

It has now been placed under the details panel when you open the mesh in the mesh viewer/editor > LOD0 > Build Settings >

Here you can choose the LM resolution and make sure you have Generate Lightmap UVs checked before you hit apply.

After this you will need to find Lightmap Coordinate Index and make sure that it is set to 1 for the newly created lightmap.



I get crashes now every time i use the feature.


Unknown exception - code 00000001 (first/second chance not available)

Assertion failed: (Index >= 0) & (Index < ArrayNum) [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.5\Engine\Source\Runtime\Core\Public\Containers\Array.h] [Line: 536]
Array index out of bounds: 0 from an array of size 0

KERNELBASE + 37901 bytes
UE4Editor_Core + 3174852 bytes
UE4Editor_Core + 1677512 bytes
UE4Editor_Core + 1566866 bytes
UE4Editor_MeshUtilities + 207765 bytes
UE4Editor_MeshUtilities + 143459 bytes
UE4Editor_Engine + 8364051 bytes
UE4Editor_Engine + 8365276 bytes
UE4Editor_Engine + 8345177 bytes
UE4Editor_Engine + 8538284 bytes
UE4Editor_CoreUObject + 1064249 bytes
UE4Editor_StaticMeshEditor + 229630 bytes
UE4Editor_StaticMeshEditor + 456419 bytes
UE4Editor_StaticMeshEditor + 315439 bytes
UE4Editor_Slate + 2103098 bytes
UE4Editor_Slate + 2285477 bytes
UE4Editor_Slate + 822092 bytes
UE4Editor_Slate + 756518 bytes
UE4Editor_Core + 2506393 bytes
UE4Editor_Core + 2450091 bytes
UE4Editor_Core + 2510873 bytes
UE4Editor_Core + 2438466 bytes
user32 + 105425 bytes
user32 + 104666 bytes
UE4Editor_Core + 3157718 bytes
UE4Editor!FEngineLoop::Tick() + 3106 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.5\engine\source\runtime\launch\private\launchengineloop.cpp:2111]
UE4Editor!GuardedMain() + 479 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.5\engine\source\runtime\launch\private\launch.cpp:133]
UE4Editor!GuardedMainWrapper() + 26 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.5\engine\source\runtime\launch\private\windows\launchwindows.cpp:125]
UE4Editor!WinMain() + 249 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.5\engine\source\runtime\launch\private\windows\launchwindows.cpp:201]
UE4Editor!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]

This sounds like a bug I’ve reported with the generated LMs settings already with ticket UE-3102.

Can you do me a favor and provide the following:

  • Zip the crash folder that is created in this location: X: \ Users \ [ Your Computer Name ] \ AppData \ Local \ Microsoft \ Windows \ WER \ ReportQueue \

  • In your Unreal Projects folder (usually in documents) can you include the crash log and dmp from “Saved \ Logs.”

This information will be relevant for me to attach to the bug report above.

Now for a little workaround and testing something to make sure we have the same issue:

Can you post a screen shot of your settings you’re using in the Mesh Editor details panel where I indicated to change the build settings for the LM?

Thank you!


sorry for the late reply link text